Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: testarossa cold start idles rough

  1. #1
    Join Date
    Feb 2008
    Location
    Reading Berks UK
    Name
    Ross lillywhite
    Posts
    125

    Default testarossa cold start idles rough

    when cold, car will start for and run 1 sec, 2nd crank run for 3 secs , 3rd crank run at 600 revs as rough as anything and no throttle response, give it 10 mins and warms up and is perfect .cold start injectors / circuit presume fine, last owner said it was fine till laid up for a year..any ideas, will clean all elec connections tomorrow.

  2. #2
    Iain is offline Overpriced piece of old tat - Ferrari 250 GTO Club Member
    Join Date
    Nov 2005
    Location
    .
    Name
    Iain
    Posts
    7,173

    Default

    Quote Originally Posted by ross View Post
    when cold, car will start for and run 1 sec, 2nd crank run for 3 secs , 3rd crank run at 600 revs as rough as anything and no throttle response, give it 10 mins and warms up and is perfect .cold start injectors / circuit presume fine, last owner said it was fine till laid up for a year..any ideas, will clean all elec connections tomorrow.
    Start looking for air leaks around the CIS system & also splits in vacuum lines. The CIS warm up doesn't work properly unless its sealed.

  3. #3
    Join Date
    Feb 2008
    Location
    Reading Berks UK
    Name
    Ross lillywhite
    Posts
    125

    Default

    cheers got this week off to do the brakes, and a list of probs will check air leaks, vacuum pipes and all connections too

  4. #4
    Iain is offline Overpriced piece of old tat - Ferrari 250 GTO Club Member
    Join Date
    Nov 2005
    Location
    .
    Name
    Iain
    Posts
    7,173

    Default

    Quote Originally Posted by ross View Post
    cheers got this week off to do the brakes, and a list of probs will check air leaks, vacuum pipes and all connections too
    Alot of those hoses will probably be cloth braided (if its anything like the 308/328) & so its quite difficult to check them for splits & leaks etc. Think Automotive in Isleworth would be your best bet for replacing those.

    Also, trace/check the vacuum lines back to the engine management box(es) - found a big hole in the one on my 328 a while back that was well & truely screwing everything up (and that meant I was getting no vacuum advance on the timing either).

  5. #5
    Join Date
    Jul 2007
    Location
    sheffield
    Name
    clive p
    Posts
    401

    Default

    Ross just a tip I read re testas, when jacking to remove front wheels advice is to jack both sides as screen so big it can crack if jacked on one side only. Dont know if this is genuine but they run approx 1000 and can be a real pain apparently.
    Good luck with the jobs this week mate and am enjoying your posts.
    Clive

  6. #6
    Join Date
    Jan 2009
    Location
    Fixing someone's f-car
    Name
    Ed
    Posts
    622

    Default

    Try it with the plugs on the cold start injectors disconnected. The base engine mixture might be too rich, and when the cold start is on as well it would be very rich.

  7. #7
    Dale's Avatar
    Dale is offline Looks like a 308 to me? -The Ferrari 288 GTO Expert
    Join Date
    Nov 2005
    Location
    uk
    Name
    Dale
    Posts
    2,613

    Default

    Quote Originally Posted by ross View Post
    when cold, car will start for and run 1 sec, 2nd crank run for 3 secs , 3rd crank run at 600 revs as rough as anything and no throttle response, give it 10 mins and warms up and is perfect .cold start injectors / circuit presume fine, last owner said it was fine till laid up for a year..any ideas, will clean all elec connections tomorrow.
    Ross WHO service's your car.

  8. #8
    Join Date
    Feb 2008
    Location
    Reading Berks UK
    Name
    Ross lillywhite
    Posts
    125

    Default

    i have only just got it, previous owner said its been like it since it was for sale at a dealers for a year, so originally thought they,d steamcleaned and got water in somewhere.
    so working my way through a list of mechanical faults. at least i got the central locking working today.

  9. #9
    Join Date
    Feb 2008
    Location
    Reading Berks UK
    Name
    Ross lillywhite
    Posts
    125

    Default fixed and ordered parts from usa

    been on it all morning but finally diagnosed rough cold start and running, found no voltage at temp sensor and traced back to fused relay in box under o/s/r wing. power to it,good earth, feed when cranking even but none out so linked out and now runs great . ferrari price just over 300. place in usa 1-3 days priority post $150 delivered
    just now have to reassemble car and hope relay arrives by saturday.... well pleased
    good old italian electrics,

  10. #10
    Join Date
    Nov 2005
    Location
    12 Cylinder Village
    Name
    Si
    Posts
    13,437

    Default

    Quote Originally Posted by ross View Post
    been on it all morning but finally diagnosed rough cold start and running, found no voltage at temp sensor and traced back to fused relay in box under o/s/r wing. power to it,good earth, feed when cranking even but none out so linked out and now runs great . ferrari price just over 300. place in usa 1-3 days priority post $150 delivered
    just now have to reassemble car and hope relay arrives by saturday.... well pleased
    good old italian electrics,
    I got this relay out of a 928 Porsche or rather stevef did and cost me nowt works fine but does'nt have the fuse on top, yours will, did you get it from Ricambi they sell them at about 65 IIRC

Page 1 of 2 12 LastLast

Similar Threads

  1. 360 Rough Start Up
    By JohnJStewart in forum Technical Q & A
    Replies: 7
    Last Post: 17-04-2009, 01:44 PM
  2. Mondial cold start
    By Trevsked in forum Technical Q & A
    Replies: 13
    Last Post: 14-08-2007, 05:14 PM
  3. Testarossa info wanted. Please be gentle.
    By renmure in forum Ferrari Talk
    Replies: 38
    Last Post: 09-05-2006, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •