Results 1 to 6 of 6

Thread: 355 tripping hidden 30amp fuse

  1. #1
    Join Date
    Jul 2018
    Location
    UK
    Name
    Ben
    Posts
    43

    Default 355 tripping hidden 30amp fuse

    Hello

    I have an issue with my LHD 96 355 spider 5.2 where the hidden 30 amp fuse is constantly blowing, this is currently on a circuit breaker so I need to keep resetting the breaker, it usually trips again less than a minute later. I would like to finally fix the underlying issue.

    Can anyone help me troubleshoot, I’m not sure where each component is located, I’ve read that disconnecting relay 04269 will rule out the clutch compressor but I’m not sure which relay this is, the manual doesn’t seem to pinpoint this?
    Last edited by ben111; 15-05-2021 at 11:50 AM.

  2. #2
    A348W's Avatar
    A348W is offline Only 37 known common faults - The Ferrari 355 Club Member
    Join Date
    Oct 2013
    Location
    North Wiltshire
    Name
    Adrian
    Posts
    1,107

    Default

    Rings a bell. Have you searched fchat?

  3. #3
    Join Date
    Jul 2018
    Location
    UK
    Name
    Ben
    Posts
    43

    Default

    Quote Originally Posted by A348W View Post
    Rings a bell. Have you searched fchat?
    Yes, That is where I read the relay tip, however I wasn’t able to find where it was situated.

    I have created a thread over there also, The car will be having an engine out service in due course so would like to determine the cause to this issue beforehand so that I know if anything in the engine bay needs replacing at the same time

  4. #4
    irarref's Avatar
    irarref is offline Kid's bed - The Ferrari F50 Club Member
    Join Date
    Oct 2011
    Location
    North West
    Name
    Jeff
    Posts
    3,500

    Default

    Does it make a difference if you keep the fan speed on your heater very slow?

    I'd suspect your "powerpack" which is in the front boot. Sadly a NLA part but Miro on FChat has a thread (which I cant find) about repairing/upgrading them

  5. #5
    Join Date
    Jul 2018
    Location
    UK
    Name
    Ben
    Posts
    43

    Default

    Quote Originally Posted by irarref View Post
    Does it make a difference if you keep the fan speed on your heater very slow?

    I'd suspect your "powerpack" which is in the front boot. Sadly a NLA part but Miro on FChat has a thread (which I cant find) about repairing/upgrading them
    I donít believe that did make a difference, I am sure I have tried alternating the speed.

    Powerpack, havenít come across that. Iíve read the compressor or heater valve motor is usually the culprits to this issue.

  6. #6
    Join Date
    Mar 2015
    Location
    Sydney
    Name
    Ian Riddell
    Posts
    139

    Default

    The "powerpack" is another name for the fan regulator.

Similar Threads

  1. Fuse
    By zambesi0 in forum Ferrari Talk
    Replies: 1
    Last Post: 28-03-2019, 03:46 PM
  2. 355 FUSE BOX HELP!!!
    By cappsy in forum Technical Q & A
    Replies: 6
    Last Post: 16-05-2009, 07:44 PM
  3. any hidden 550's?
    By goldsax in forum Ferrari Talk
    Replies: 2
    Last Post: 12-02-2007, 06:52 PM
  4. 456 Fuse box
    By andy456M in forum Technical Q & A
    Replies: 7
    Last Post: 01-11-2006, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •